PENERAPAN ROUTER OSPF DAN LOOPBACK PADA SEBUAH TOPOLOGI JARINGAN


Sebelum kita membahas tentang bagaimana cara menerapkan konfigurasi router OSPF pada sebuah Topologi Jaringan, ada baiknya kita mengetahui terlebih dahulu pengertian dari OSPF.

 

 

 

Definisi OSPF (Open Shortest Path First)

 

OSPF merupakan sebuah routing protokol berjenis IGP yang hanya dapat bekerja dalam jaringan internal suatu ogranisasi atau perusahaan. Jaringan internal maksudnya adalah jaringan dimana user masih memiliki hak untuk menggunakan, mengatur, dan memodifikasinya. Atau dengan kata lain, user masih memiliki hak administrasi terhadap jaringan tersebut. Jika user sudah tidak memiliki hak untuk menggunakan dan mengaturnya, maka jaringan tersebut dapat dikategorikan sebagai jaringan eksternal. Selain itu, OSPF juga merupakan routing protokol yang berstandar terbuka. Maksudnya adalah routing protokol ini bukan ciptaan dari vendor manapun. Dengan demikian, siapapun dapat menggunakannya, perangkat manapun dapat kompatibel dengannya, dan dimanapun routing protokol ini dapat diimplementasikan.

 

 

 

Seperti telah dijelaskan di atas, OSPF harus membentuk hubungan dulu dengan router tetangganya untuk dapat saling berkomunikasi seputar informasi routing. Untuk membentuk sebuah hubungan dengan router tetangganya, OSPF mengandalkan Hello protocol. Namun uniknya cara kerja Hello protocol pada OSPF berbeda-beda pada setiap jenis media. Ada beberapa jenis media yang dapat meneruskan informasi OSPF, masing-masing memiliki karakteristik sendiri, sehingga OSPF pun bekerja mengikuti karakteristik mereka. Media tersebut adalah sebagai berikut:

 

 

   

 

 

 

 

 

 

 

Broadcast Multiaccess

 

Media jenis ini adalah media yang banyak terdapat dalam jaringan lokal atau LAN seperti misalnya ethernet, FDDI, dan token ring. Dalam kondisi media seperti ini, OSPF akan mengirimkan traffic multicast dalam pencarian router-router neighbour-nya. Namun ada yang unik dalam proses pada media ini, yaitu akan terpilih dua buah router yang berfungsi sebagai Designated Router (DR) dan Backup Designated Router (BDR).

 

 

 

 

 

 

 

Baiklah kali ini kita akan mengkonfigurasikan topologi berikut dengan menggunakan OSPF

 

 

 

 

 


 

 

 





 

PENERAPAN ROUTER OSPF DAN LOOPINGBACK PADA SEBUAH TOPOLOGI JARINGAN

 

 

Kofigurasi  switch yang bertindak sebagai Server :

Beri nama pada Switch :

Switch0>enable

Switch0#configure terminal

Switch0(config)#hostname Server

Server (config)#exit

 

Create vlan :

Server#configure terminal

Server (config)#vlan 2

Server (config-vlan)#name TKJ2

Server (config-vlan)#vlan 3

Server (config-vlan)#name TKJ3

Server (config-vlan)#vlan 4

Server (config-vlan)#name TKJ4

Server (config-vlan)#vlan 5

Server (config-vlan)#name TKJ5

Server (config-vlan)#vlan 6

Server (config-vlan)#name TKJ6

Server (config-vlan)#exit

Server (config)#exit

 

Beri ip pada Server :

Server#configure terminal

Server (config)#interface vlan 1

Server (config-if)#ip address 192.168.0.2 255.255.255.240

Server (config-if)#no shutdown

Server (config-if)#exit

Server (config)#exit

 

Lakukan perintah trunking port pada Server yang merupakan pembagian anggota vlan:

Server#configure terminal

Server (config)#interface fastEthernet 0/1

Server (config-if)#switchport mode trunk

Server (config-if)#switchport trunk native vlan 1

Server (config-if)#exit

Server (config)#interface fastEthernet 0/2

Server (config-if)#switchport mode  access

Server (config-if)#switchport access vlan 2

Server (config-if)#interface fastEthernet 0/3

Server (config-if)#switchport mode  access

Server (config-if)#switchport access vlan 3

Server (config-if)#interface fastEthernet 0/4

Server (config-if)#switchport mode  access

Server (config-if)#switchport access vlan 4

Server (config-if)#interface fastEthernet 0/5

Server (config-if)#switchport mode  access

Server (config-if)#switchport access vlan 5

Server (config-if)#interface fastEthernet 0/6

Server (config-if)#switchport mode  access

Server (config-if)#switchport access vlan 6

Server (config-if)#end

 

 

Konfigurasi pada Router Pusat :

 

 

Langkah awal yang harus dilakukan pada Router pusat adalah memberikan nama, lalu aktifkan tiap port pada Router dan beri ip di tiap-tiap interface:

 

Router0>enable

Router0#configure terminal

Router0(config)#hostname RouterPusat

RouterPusat (config)#interface FastEthernet0/0

RouterPusat (config-if)#ip address 192.168.0.1 255.255.255.240

RouterPusat (config-if)#no shutdown

RouterPusat (config-if)#exit

RouterPusat (config)#interface FastEthernet0/1

RouterPusat (config-if)#ip address 172.10.0.1 255.255.255.0

RouterPusat (config-if)#no shutdown

RouterPusat (config-if)#exit

RouterPusat (config)#exit

 

 

Lakukan perintah enkasulasi dengan menggunakan konfigurasi dot1Q :

RouterPusat #configure terminal

RouterPusat (config)#interface fastEthernet 0/0.2

RouterPusat (config-subif)#encapsulation dot1Q 2

RouterPusat (config-subif)#ip address 192.168.0.17 255.255.255.240

RouterPusat (config-subif)#interface fastEthernet 0/0.3

RouterPusat (config-subif)#encapsulation dot1Q 3

RouterPusat (config-subif)#ip address 192.168.0.33 255.255.255.240

RouterPusat (config-subif)#interface fastEthernet 0/0.4

RouterPusat (config-subif)#encapsulation dot1Q 4

RouterPusat (config-subif)#ip address 192.168.0.49 255.255.255.240

RouterPusat (config-subif)#interface fastEthernet 0/0.5

RouterPusat (config-subif)#encapsulation dot1Q 5

RouterPusat (config-subif)#ip address 192.168.0.65 255.255.255.240

RouterPusat (config-subif)#interface fastEthernet 0/0.6

RouterPusat (config-subif)#encapsulation dot1Q 6

RouterPusat (config-subif)#ip address 192.168.0.81 255.255.255.240

RouterPusat (config-subif)#exit

RouterPusat (config)#exit

 

 

 Kemudian lakukan perintah loopback :

 

RouterPusat #configure terminal

RouterPusat (config)#interface loopback 0

RouterPusat (config-if)#ip address 192.168.0.1 255.255.255.255

RouterPusat (config-if)#exit

RouterPusat (config)#router ospf 1

RouterPusat (config-router)#network 192.168.0.1 0.0.0.0 area 0

RouterPusat (config-router)#network 192.168.0.16 0.0.0.15 area 0

RouterPusat (config-router)#network 192.168.0.32 0.0.0.15 area 0

RouterPusat (config-router)#network 192.168.0.48 0.0.0.15 area 0

RouterPusat (config-router)#network 192.168.0.64 0.0.0.15 area 0

RouterPusat (config-router)#network 192.168.0.80 0.0.0.15 area 0

RouterPusat (config-router)#router-id 192.168.0.1

RouterPusat (config-router)#log-adjacency-changes

RouterPusat (config-router)#end

 

 

Konfigurasi pada ROUTER 1 :

 

Beri ip address pada tiap port :

Router1>enable

Router1#configure terminal

Router1(config)#interface FastEthernet0/0

Router1(config-if)#ip address 192.168.0.18 255.255.255.240

Router1(config-if)#no shutdown

Router1(config-if)#exit

Router1(config)#interface FastEthernet0/1

Router1(config-if)#ip address 172.17.0.1 255.255.0.0

Router1(config-if)#ip address 172.17.0.1 255.255.255.0

Router1(config-if)#no shutdown

Router1(config-if)#exit

 

Lakukan konfigurasi loopback untuk menerapkan router ospf pada router :

Router1(config)#interface loopback 0

Router1(config-if)#ip address 192.168.0.2 255.255.255.255

Router1(config-if)#exit

Router1(config)#router ospf 1

Router1(config-router)#network 192.168.0.16 0.0.0.15 area 0

Router1(config-router)#network 172.17.0.0 0.0.0.255 area 0

Router1(config-router)#network 192. 168.0.2 0.0.0.0 area 0

Router1(config-router)#router-id 192.168.0.2

Router1(config-router)#log-adjacency-changes

Router1(config-router)#end

 

 

 

Konfigurasi pada ROUTER 2 :

 

Beri ip address pada tiap port :

Router2>enable

Router2#configure terminal

Router2(config)#interface FastEthernet0/0

Router2(config-if)#ip address 192.168.0.34 255.255.255.240

Router2(config-if)#no shutdown

Router2(config-if)#exit

Router2(config)#interface FastEthernet0/1

Router2(config-if)#ip address 172.17.1.1 255.255.0.0

Router2(config-if)#ip address 172.17.1.1 255.255.255.0

Router2(config-if)#no shutdown

Router2(config-if)#exit

 

 

 

Lakukan konfigurasi loopback untuk menerapkan router ospf pada router :

Router2(config)#interface loopback 0

Router2(config-if)#ip address 192.168.0.3 255.255.255.255

Router2(config-if)#exit

Router2(config)#router ospf 1

Router2(config-router)#network 192.168.0.32 0.0.0.15 area 0

Router2(config-router)#network 172.17.1.0 0.0.0.255 area 0

Router2(config-router)#network 192.168.0.3 0.0.0.0 area 0

Router2(config-router)#router-id 192.168.0.3

Router2(config-router)#log-adjacency-changes

Router2(config-router)#end

 

 

Konfigurasi pada ROUTER 3 :

 

Beri ip address pada tiap port :

Router3>enable

Router3#configure terminal

Router3(config)#interface FastEthernet0/0

Router3(config-if)#ip address 192.168.0.50 255.255.255.240

Router3(config-if)#no shutdown

Router3(config-if)#exit

Router3(config)#interface FastEthernet0/1

Router3(config-if)#ip address 172.17.2.1 255.255.0.0

Router3(config-if)#ip address 172.17.2.1 255.255.255.0

Router3(config-if)#no shutdown

Router3(config-if)#exit

 

Lakukan konfigurasi loopback untuk menerapkan router ospf pada router :

 

Router3(config)#interface loopback 0

Router3(config-if)#ip address 192.168.0.2 255.255.255.255

Router3(config-if)#exit

Router3(config)#router ospf 1

Router3(config-router)#network 192.168.0.48 0.0.0.15 area 0

Router3(config-router)#network 172.17.2.0 0.0.0.255 area 0

Router3(config-router)#network 192. 168.0.4 0.0.0.0 area 0

Router3(config-router)#router-id 192.168.0.4

Router3(config-router)#log-adjacency-changes

Router3(config-router)#end

 

 

Konfigurasi pada ROUTER 4 :

 

Beri ip address pada tiap port :

Router4>enable

Router4#configure terminal

Router4(config)#interface FastEthernet0/0

Router4(config-if)#ip address 192.168.0.66 255.255.255.240

Router4(config-if)#no shutdown

Router4(config-if)#exit

Router4(config)#interface FastEthernet0/1

Router4(config-if)#ip address 172.17.3.1 255.255.0.0

Router4(config-if)#ip address 172.17.3.1 255.255.255.0

Router4(config-if)#no shutdown

Router4(config-if)#exit

 

Lakukan konfigurasi loopback untuk menerapkan router ospf pada router :

 

Router4(config)#interface loopback 0

Router4(config-if)#ip address 192.168.0.5 255.255.255.255

Router4(config-if)#exit

Router4(config)#router ospf 1

Router4(config-router)#network 192.168.0.64 0.0.0.15 area 0

Router4(config-router)#network 172.17.3.0 0.0.0.255 area 0

Router4(config-router)#network 192.168.0.5 0.0.0. 0 area 0

Router4(config-router)#router-id 192.168.0.5

Router4(config-router)#log-adjacency-changes

Router4(config-router)#end

 

Konfigurasi pada ROUTER 5 :

 

Beri ip address pada tiap port :

Router5>enable

Router5#configure terminal

Router5(config)#interface FastEthernet0/0

Router5(config-if)#ip address 192.168.0.82 255.255.255.240

Router5(config-if)#no shutdown

Router5(config-if)#exit

Router5(config)#interface FastEthernet0/1

Router5(config-if)#ip address 172.17.4.1 255.255.0.0

Router5(config-if)#ip address 172.17.4.1 255.255.255.0

Router5(config-if)#no shutdown

Router5(config-if)#exit

 

Lakukan konfigurasi loopback untuk menerapkan router ospf pada router :

 

Router5(config)#interface loopback 0

Router5(config-if)#ip address 192.168.0.6 255.255.255.255

Router5(config-if)#exit

Router5(config)#router ospf 1

Router5(config-router)#network 192.168.0.80 0.0.0.15 area 0

Router5(config-router)#network 172.17.4.0 0.0.0.255 area 0

Router5(config-router)#network 192.168.0.6 0.0.0.0 area 0

Router5(config-router)#router-id 192.168.0.6

Router5(config-router)#log-adjacency-changes

Router5(config-router)#end

 

 

Berikut tabel daftar ip network berdasarkan topologi yang telah kita buat :

 

 

Router id

Ip Network

Router1

192.168.0.1/32

Router2

192.168.0.2/32

Router3

192.168.0.3/32

Router4

192.168.0.4/32

Router5

192.168.0.5/32

Router6

192.168.0.6/32

 

 

Vlan

Ip Network

Vlan1

192.168.0.1/28

Vlan2

192.168.0.16/28

Vlan3

192.168.0.32/28

Vlan4

192.168.0.48/28

Vlan5

192.168.0.64/28

Vlan6

192.168.0.80/28

 

 

 

Sumber : dari berbagai sumber

 

 



PDF | DOC | DOCX

Komentar:

 
19 Desember 2010 pukul 12:49 WIB
mona luana mengatakan...
 

ya ya ya

04 Mei 2010 pukul 16:02 WIB
ryu mengatakan...
 

cool smirk cool smirk cool smirk hem lmyan, tapi harus dibuat dari satu artikel aja. oya salam kenal y mona luana. hehehhehe

22 April 2010 pukul 11:36 WIB
putra mengatakan...
 

bagus.... tapi knpa banyak sekali artikel nya... mana yang benar.... question


Kirim Komentar Anda:
Nama Anda (wajib diisi)
 
E-Mail (tidak dipublikasikan)
 
Website, Blog, Facebook, dll
 
(wajib diisi)
 

<-- isi kode di atas (wajib diisi)
 
 
grinLOLcheesesmilewinksmirkrolleyesconfused
surprisedbig surprisetongue laughtongue rolleyetongue winkraspberryblank starelong face
ohhgrrrgulpoh ohdownerred facesickshut eye
hmmmmadangryzipperkissshockcool smilecool smirk
cool grincool hmmcool madcool cheesevampiresnakeexcaimquestion


Free Blog Content